Publication Post Submission Delays and Layout Issues
Resolved·Degraded performance

All fixes related to anomalous Publications behaviors have been deployed. Specifically, these changes have addressed behaviors including:

  • Posts failing to appear

  • Posts mistakenly appearing where they should not

  • Layout changes not reflected in a timely manner

At this time, we no long expect these behaviors to persist. If any abnormalities are observed with relation to Publications, please open a new issue via help.medium.com.

Fri, Nov 14, 2025, 07:24 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

All fixes related to anomalous Publications behaviors have been deployed. Specifically, these changes have addressed behaviors including:

  • Posts failing to appear

  • Posts mistakenly appearing where they should not

  • Layout changes not reflected in a timely manner

At this time, we no long expect these behaviors to persist. If any abnormalities are observed with relation to Publications, please open a new issue via help.medium.com.

Fri, Nov 14, 2025, 07:24 PM

Identified

Additional improvements have been shipped to stabilize the behaviors observed by editors in Publications, including:

  • Posts failing to appear

  • Posts mistakenly appearing where they should not

  • Layout changes not reflected in a timely manner

We are confident that layout issues are now resolved, and that a large majority of post-related issues are as well. Some users may still experience abnormalities. We are actively working on changes to address the issue as quickly as possible. While we deploy additional fixes, we expect some post ordering may change within publications. If you experience any undesired behavior within your publication, please contact us at help.medium.com so that we can ensure your specific issues are taken into account and addressed swiftly.

Wed, Nov 12, 2025, 09:54 PM(1 day earlier)

Identified

We have shipped a large number of improvements that have largely decreased the number of posts failing to appear in Publications. In addition, work has been done to stabilize other surfaces relating to Publications and their layouts. We are confident that a large majority of the behaviors observed have been stabilized, but acknowledge that some users may still experience abnormalities. If you experience undesired behavior in your publication, please contact us at help.medium.com so that we can better understand the nature of the problem, and address it as soon as possible.

Fri, Oct 31, 2025, 05:54 PM(1 week earlier)

Investigating

We are seeing improvements from the changes we have deployed, and can confirm reduced frequency in the issues related to posts being shared in publications. We are continuing to improve the reliability of this product surface, and will continue to provide updates as we validate the impact of our changes as they relate to specific behaviors. We appreciate the patience as we continue to investigate and apply fixes as quickly as possible. If you continue to experience any issues with your publication, please submit a request at help.medium.com

Thu, Oct 30, 2025, 08:07 PM(21 hours earlier)

Investigating

Update - 27-October Some additional fixes have taken effect as of today. We are seeing improvements in new posts showing up in Publications. This behavior should be visibly improved. Please continue reporting any new occurrences of this behavior, as we are still working to improve the experience in Publications. Some other problematic behaviors remain and are still being investigated. These include (but are not limited to) posts appearing in Publications that should no longer do so and layout updates not being immediately reflected. We will continue to provide updates as additional improvements deploy.

Mon, Oct 27, 2025, 09:25 PM(2 days earlier)

Investigating

Numerous improvements have been shipped this week. While we still see some degraded performance and abnormal behavior with publication pages, we are beginning to see improved backend performance. Some additional fixes are still underway, and we will continue to provide updates as further improvements are made to the components powering publications. In the meantime, please continue to report abnormalities as they are encountered.

Fri, Oct 24, 2025, 09:54 PM(2 days earlier)

Investigating

We appreciate your patience.

We have identified the missing core data dependencies that connect stories with publications, and are working to fix those now. Please bear with us.

Wed, Oct 22, 2025, 09:59 PM(1 day earlier)

Investigating

There continue to be delays when performing certain actions within publications. There are multiple, parallel efforts underway to address the issue. Some fixes have already shipped, so we are hopeful the experience will improve soon. More updates to follow as we ship more fixes directly tied to this issue.

Wed, Oct 15, 2025, 03:08 PM(1 week earlier)

Investigating

We are aware that there may be a large delay when performing certain actions within the publication. For example, there may be a delay between the time the story is accepted and when it is displayed on the homepage, when the publication layout is updated, or when the submitted story statuses are updated.

The team is working to improve this now. Please subscribe to this status to receive updates.

Tue, Oct 14, 2025, 03:42 PM(23 hours earlier)