Resolved
This incident is now resolved.
Identified
We now better understand that this is not a widespread issue. A small subset of user traffic is being characterized as automated, and the patterns match that of traffic that may be sitting behind a specific type of network proxy. We are now investigating the best way to allow this type of legitimate traffic through our firewalls, and will update again when more information is available.
Investigating
A small number of users is reporting that they are unable to log into Medium from their corporate networks. We are actively investigating the issue and will provide an update as quickly as possible.