We have identified the root cause and a fix has been applied. New membership upgrades made through the iOS App Store are now processed and reflected accurately.
Users who were affected during the incident window or are noticing discrepancies between their App Store subscription status and Medium membership status can use the "Restore purchase" option in the Medium iOS app settings to go back to normal. Please contact Medium support if you are still experiencing issues.
Resolved
We have identified the root cause and a fix has been applied. New membership upgrades made through the iOS App Store are now processed and reflected accurately.
Users who were affected during the incident window or are noticing discrepancies between their App Store subscription status and Medium membership status can use the "Restore purchase" option in the Medium iOS app settings to go back to normal. Please contact Medium support if you are still experiencing issues.
Identified
We have identified the root cause and a fix has been applied. New membership upgrades made through the iOS App Store should now be processed and reflected accurately.
We are still working on resolving membership status for users who were affected during the incident window.
Investigating
We are aware of an issue affecting some users who recently upgraded their membership through the iOS App Store. These users may not see their updated membership status reflected accurately across the platform. Existing memberships are not affected. Our team is actively investigating the root cause and we will provide updates as more information becomes available.